• 14 Posts
Joined 1Y ago
Cake day: Dec 30, 2021


If you own the instance, you can check the database, but this is not your case.

They are just making propaganda to try to convince people to invest in their terrible company.

Did you install manually?

No, I followed the instructions for Docker.

Then you need to ensure that the ports for lemmy and lemmy-ui are set correctly in nginx config.

I think they are. This is the nginx config file:

limit_req_zone $binary_remote_addr zone=lemido.freakspot.net_ratelimit:10m rate=1r/s;

server {
    listen 80;
    listen [::]:80;
    server_name lemido.freakspot.net;
    location /.well-known/acme-challenge/ {
        root /var/www/certbot;
    location / {
        return 301 https://$host$request_uri;

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name lemido.freakspot.net;

    ssl_certificate /etc/letsencrypt/live/freakspot.net-0002/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/freakspot.net-0002/privkey.pem;

    # Various TLS hardening settings
    # https://raymii.org/s/tutorials/Strong_SSL_Security_On_nginx.html
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_prefer_server_ciphers on;
    ssl_session_timeout  10m;
    ssl_session_cache shared:SSL:10m;
    ssl_session_tickets on;
    ssl_stapling on;
    ssl_stapling_verify on;

    # Hide nginx version
    server_tokens off;

    # Enable compression for JS/CSS/HTML bundle, for improved client load times.
    # It might be nice to compress JSON, but leaving that out to protect against potential
    # compression+encryption information leak attacks like BREACH.
    gzip on;
    gzip_types text/css application/javascript image/svg+xml;
    gzip_vary on;

    # Only connect to this site via HTTPS for the two years
    add_header Strict-Transport-Security "max-age=63072000";

    # Various content security headers
    add_header Referrer-Policy "same-origin";
    add_header X-Content-Type-Options "nosniff";
    add_header X-Frame-Options "DENY";
    add_header X-XSS-Protection "1; mode=block";

    # Upload limit for pictrs
    client_max_body_size 500M;

    # frontend
    location / {
      # The default ports:
      # lemmy_ui_port: 1235
      # lemmy_port: 8536

#      Also tried this, but it didn't work

#      set $proxpass "";
#      if ($http_accept = "application/activity+json") {
#      set $proxpass "";
#      }
#      if ($http_accept = "application/ld+json; profile=\"https://www.w3.org/ns/activitystreams\"") {
#      set $proxpass "";
#      }
#      proxy_pass $proxpass;

      set $proxpass "";
      if ($http_accept ~ "^application/.*$") {
        set $proxpass "";
      if ($request_method = POST) {
        set $proxpass "";
      proxy_pass $proxpass;

      rewrite ^(.+)/+$ $1 permanent;

      # Send actual client IP upstream
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header Host $host;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

    # backend
    location ~ ^/(api|pictrs|feeds|nodeinfo|.well-known) {
      proxy_http_version 1.1;
      proxy_set_header Upgrade $http_upgrade;
      proxy_set_header Connection "upgrade";

      # Rate limit
      limit_req zone=lemido.freakspot.net_ratelimit burst=30 nodelay;

      # Add IP forwarding headers
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header Host $host;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

    # Redirect pictshare images to pictrs
    location ~ /pictshare/(.*)$ {
      return 301 /pictrs/image/$1;


# Anonymize IP addresses
# https://www.supertechcrew.com/anonymizing-logs-nginx-apache/
map $remote_addr $remote_addr_anon {
  ~(?P<ip>\d+\.\d+\.\d+)\.    $ip.0;
  ~(?P<ip>[^:]+:[^:]+):       $ip::;                   $remote_addr;
  ::1                         $remote_addr;
  default           ;
access_log /var/log/nginx/access.log combined;

You also need to apply changes with nginx -s reload

I did restart with systemctl and also used your command, but it still doesn’t work.

I copied the default nginx config, but for some reason I don’t know it doesn’t work, and I don’t know how to troubleshoot it, because I don’t see any error message.

I can read and post doing that, but my posts don’t appear on the original forum and everything has 0 votes, and I can’t see any comment.

New Lemmy Spanish-speaking instance: Lemido
Hi, I've just created an instance for Spanish speakers. I want to federate, but according to the documentation I have to ask other servers to federate with me: > Federation is not set up by default. You can add this this federation block to your lemmy.hjson, and ask other servers to add you to their allowlist. Do you want to federate with my instance? Do I need to ask to every instance with which I want to federate?